blob: 782b973b58de2dc5388b3bb52cf7830f5d96f70c [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "lib-curses provides an interface between Perl programs and \
2the curses library."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0+"
6
7LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
8
9DEPENDS += "perl ncurses "
10
11SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "389c70ee5530b887f8e5dc1303cb5294"
14SRC_URI[sha256sum] = "a414795ba031c5918c70279fe534fee594a96ec4b0c78f44ce453090796add64"
15
16S = "${WORKDIR}/Curses-${PV}"
17
18EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
19
20inherit cpan
21
22do_compile() {
23 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
24 cpan_do_compile
25}
26