blob: 6b76682c68154efb2518263651ac674003cfc19b [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Term::ReadKey - A perl module for simple terminal control."
2DESCRIPTION = "Term::ReadKey is a compiled perl module dedicated to providing simple \
3control over terminal driver modes (cbreak, raw, cooked, etc.,) support \
4for non-blocking reads, if the architecture allows, and some generalized \
5handy functions for working with terminals. One of the main goals is to \
6have the functions as portable as possible, so you can just plug in "use \
7Term::ReadKey" on any architecture and have a good likelihood of it \
8working."
9HOMEPAGE = "http://search.cpan.org/~jstowe/TermReadKey-${PV}"
10SECTION = "libraries"
11
12LICENSE = "Artistic-1.0 | GPLv1+"
13LIC_FILES_CHKSUM = "file://README;md5=c275db663c8489a5709ebb22b185add5"
14
15SRC_URI = "${CPAN_MIRROR}/authors/id/J/JS/JSTOWE/TermReadKey-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "e8ea15c16333ac4f8d146d702e83cc0c"
18SRC_URI[sha256sum] = "4a9383cf2e0e0194668fe2bd546e894ffad41d556b41d2f2f577c8db682db241"
19
20S = "${WORKDIR}/TermReadKey-${PV}"
21
22# It needs depend on native to let dynamic loader use native modules
23# rather than target ones.
24DEPENDS = "libterm-readkey-perl-native"
25
26inherit cpan
27
28do_configure_append () {
29 # Hack the dynamic module loader so that it use native modules since it can't load
30 # the target ones.
31 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
32 sed -i -e "s#-I\$(INST_ARCHLIB)#-I${STAGING_BINDIR_NATIVE}/perl-native/perl/vendor_perl/${@get_perl_version(d)}#g" Makefile
33 fi
34}
35
36BBCLASSEXTEND = "native"