blob: 34573008845288e2daa571f0f31a70cb9bdbe47c [file] [log] [blame]
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06001SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004COMPATIBLE_MACHINE = "^rpi$"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06005
6DEPENDS = "u-boot-mkimage-native"
7
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008SRC_URI = "file://boot.cmd.in"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06009
10do_compile() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 sed -e 's/@@KERNEL_IMAGETYPE@@/${KERNEL_IMAGETYPE}/' \
12 -e 's/@@KERNEL_BOOTCMD@@/${KERNEL_BOOTCMD}/' \
13 "${WORKDIR}/boot.cmd.in" > "${WORKDIR}/boot.cmd"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060014 mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
15}
16
17inherit deploy
18
19do_deploy() {
20 install -d ${DEPLOYDIR}
21 install -m 0644 boot.scr ${DEPLOYDIR}
22}
23
24addtask do_deploy after do_compile before do_build