blob: f7c4e349d17f42a394a4d872f3e64c55f91fcf4e [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission"
2HOMEPAGE = "https://github.com/RPi-Distro/python-sense-hat"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=d80fe312e1ff5fbd97369b093bf21cda"
6
7inherit setuptools pypi
8
9PYPI_PACKAGE = "sense-hat"
10
11SRC_URI[md5sum] = "69929250cb72349a8a82edf2584b1d83"
12SRC_URI[sha256sum] = "f000998d042d96ed722d459312e1bebd0107f9f3015cd34b3e4fabcab9c800af"
13
14DEPENDS += " \
15 jpeg \
16 zlib \
17 freetype \
18 "
19
20RDEPENDS_${PN} += " \
21 python-numpy \
22 python-rtimu \
23 python-imaging \
24 "