blob: d38b02d85a73755e3b53244c0b562107c7050269 [file] [log] [blame]
Patrick Williams8b8bc412016-08-17 15:02:23 -05001DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7
8PR = "r5"
9
10PROVIDES = "virtual/libgles2 \
11 virtual/egl"
12
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013RPROVIDES_${PN} += "libgles2 egl libegl"
Patrick Williams8b8bc412016-08-17 15:02:23 -050014
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015COMPATIBLE_MACHINE = "^rpi$"
Patrick Williams8b8bc412016-08-17 15:02:23 -050016
17SRCBRANCH = "master"
18SRCFORK = "raspberrypi"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019SRCREV = "bc3c52a51315399a9f31ed24049eb4bc81fd1c60"
Patrick Williams8b8bc412016-08-17 15:02:23 -050020
21SRC_URI = "\
22 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
23 file://0001-Allow-applications-to-set-next-resource-handle.patch \
24 file://0002-wayland-Add-support-for-the-Wayland-winsys.patch \
25 file://0003-wayland-Add-Wayland-example.patch \
26 file://0004-wayland-egl-Add-bcm_host-to-dependencies.patch \
27 file://0005-interface-remove-faulty-assert-to-make-weston-happy-.patch \
28 file://0006-zero-out-wl-buffers-in-egl_surface_free.patch \
29 file://0007-initialize-front-back-wayland-buffers.patch \
30 file://0008-Remove-RPC_FLUSH.patch \
31 file://0009-fix-cmake-dependency-race.patch \
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060032 file://0010-Fix-for-framerate-with-nested-composition.patch \
33 file://0011-build-shared-library-for-vchostif.patch \
34 file://0012-implement-buffer-wrapping-interface-for-dispmanx.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035 file://0013-Implement-triple-buffering-for-wayland.patch \
36 file://0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch \
37 file://0015-EGL-glplatform.h-define-EGL_CAST.patch \
Patrick Williams8b8bc412016-08-17 15:02:23 -050038"
39S = "${WORKDIR}/git"
40
41inherit cmake pkgconfig
42
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060043ASNEEDED = ""
44
Patrick Williams8b8bc412016-08-17 15:02:23 -050045EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release -DCMAKE_EXE_LINKER_FLAGS='-Wl,--no-as-needed' \
46 -DVMCS_INSTALL_PREFIX=${exec_prefix} \
47"
48
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060049EXTRA_OECMAKE_append_aarch64 = " -DARM64=ON "
50
51
Patrick Williams8b8bc412016-08-17 15:02:23 -050052PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
53
54PACKAGECONFIG[wayland] = "-DBUILD_WAYLAND=TRUE -DWAYLAND_SCANNER_EXECUTABLE:FILEPATH=${STAGING_BINDIR_NATIVE}/wayland-scanner,,wayland-native wayland"
55
56CFLAGS_append = " -fPIC"
57
58do_install_append () {
59 for f in `find ${D}${includedir}/interface/vcos/ -name "*.h"`; do
60 sed -i 's/include "vcos_platform.h"/include "pthreads\/vcos_platform.h"/g' ${f}
61 sed -i 's/include "vcos_futex_mutex.h"/include "pthreads\/vcos_futex_mutex.h"/g' ${f}
62 sed -i 's/include "vcos_platform_types.h"/include "pthreads\/vcos_platform_types.h"/g' ${f}
63 done
64}
65
66# Shared libs from userland package build aren't versioned, so we need
67# to force the .so files into the runtime package (and keep them
68# out of -dev package).
69FILES_SOLIBSDEV = ""
70INSANE_SKIP_${PN} += "dev-so"
71
72FILES_${PN} += " \
73 ${libdir}/*.so \
74 ${libdir}/plugins"
75FILES_${PN}-dev += "${includedir} \
76 ${prefix}/src"
77FILES_${PN}-doc += "${datadir}/install"
78FILES_${PN}-dbg += "${libdir}/plugins/.debug"
79
80PACKAGE_ARCH = "${MACHINE_ARCH}"
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -060081
82RDEPENDS_${PN} += "bash"