blob: 3e61f6a16d03277b308d04e2b2d4e4a2480807b4 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
3RDEPENDS_${PN} += "diffutils freetype"
4
5do_install_append () {
6 install -d ${D}${sysconfdir}/grub.d
7 # Remove build host references...
8 find "${D}" -name modinfo.sh -type f -exec \
9 sed -i \
10 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
11 -e 's|${DEBUG_PREFIX_MAP}||g' \
12 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
13 {} +
14}
15
16INSANE_SKIP_${PN} = "arch"
17INSANE_SKIP_${PN}-dbg = "arch"