blob: 0d2b8bf52ff3185171f4c85e46a7c37b498ef2db [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "boot image with UEFI shell and tools"
2
3# For this image recipe, only the wic format with a
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004# single vfat partition makes sense. Because we have no
5# boot loader and no rootfs partition, not additional
6# tools are needed for this .wks file.
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007IMAGE_FSTYPES_forcevariable = 'wic'
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008WKS_FILE = "ovmf/ovmf-shell-image.wks"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009WKS_FILE_DEPENDS = ""
10
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011inherit image
12
13# We want a minimal image with just ovmf-shell-efi unpacked in it. We
14# avoid installing unnecessary stuff as much as possible, but some
15# things still get through and need to be removed.
16PACKAGE_INSTALL = "ovmf-shell-efi"
17LINGUAS_INSTALL = ""
18do_image () {
19 rm -rf `ls -d ${IMAGE_ROOTFS}/* | grep -v efi`
20}