blob: 7b70daa323d8a9d17e4d8344ced9a0cd6a255293 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "cve-check-tool"
2DESCRIPTION = "cve-check-tool is a tool for checking known (public) CVEs.\
3The tool will identify potentially vunlnerable software packages within Linux distributions through version matching."
4HOMEPAGE = "https://github.com/ikeydoherty/cve-check-tool"
5SECTION = "Development/Tools"
6LICENSE = "GPL-2.0+"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e8c1458438ead3c34974bc0be3a03ed6"
8
9SRC_URI = "https://github.com/ikeydoherty/${BPN}/releases/download/v${PV}/${BP}.tar.xz \
10 file://check-for-malloc_trim-before-using-it.patch \
11 file://0001-print-progress-in-percent-when-downloading-CVE-db.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012 file://0001-curl-allow-overriding-default-CA-certificate-file.patch \
13 file://0001-update-Compare-computed-vs-expected-sha256-digit-str.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0001-Fix-freeing-memory-allocated-by-sqlite.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060015 "
16
17SRC_URI[md5sum] = "c5f4247140fc9be3bf41491d31a34155"
18SRC_URI[sha256sum] = "b8f283be718af8d31232ac1bfc10a0378fb958aaaa49af39168f8acf501e6a5b"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020UPSTREAM_CHECK_URI = "https://github.com/ikeydoherty/cve-check-tool/releases"
21
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022DEPENDS = "libcheck glib-2.0 json-glib curl libxml2 sqlite3 openssl ca-certificates"
23
24RDEPENDS_${PN} = "ca-certificates"
25
26inherit pkgconfig autotools
27
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028EXTRA_OECONF = "--disable-coverage --enable-relative-plugins"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029CFLAGS_append = " -Wno-error=pedantic"
30
31do_populate_cve_db() {
32 if [ "${BB_NO_NETWORK}" = "1" ] ; then
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 bbwarn "BB_NO_NETWORK is set; Can't update cve-check-tool database, new CVEs won't be detected"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034 return
35 fi
36
37 # In case we don't inherit cve-check class, use default values defined in the class.
38 cve_dir="${CVE_CHECK_DB_DIR}"
39 cve_file="${CVE_CHECK_TMP_FILE}"
40
41 [ -z "${cve_dir}" ] && cve_dir="${DL_DIR}/CVE_CHECK"
42 [ -z "${cve_file}" ] && cve_file="${TMPDIR}/cve_check"
43
44 bbdebug 2 "Updating cve-check-tool database located in $cve_dir"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050045 # --cacert works around curl-native not finding the CA bundle
46 if cve-check-update --cacert ${sysconfdir}/ssl/certs/ca-certificates.crt -d "$cve_dir" ; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -060047 printf "CVE database was updated on %s UTC\n\n" "$(LANG=C date --utc +'%F %T')" > "$cve_file"
48 else
49 bbwarn "Error in executing cve-check-update"
50 if [ "${@'1' if bb.data.inherits_class('cve-check', d) else '0'}" -ne 0 ] ; then
51 bbwarn "Failed to update cve-check-tool database, CVEs won't be checked"
52 fi
53 fi
54}
55
56addtask populate_cve_db after do_populate_sysroot
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057do_populate_cve_db[depends] = "cve-check-tool-native:do_populate_sysroot"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058do_populate_cve_db[nostamp] = "1"
59do_populate_cve_db[progress] = "percent"
60
61BBCLASSEXTEND = "native nativesdk"