blob: a3077a9fff11cad10fc489ca64a1c56dda58ae10 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "408300ed09d1ad5938070158b21da1d1"
11SRC_URI[sha256sum] = "e6db91a24e68c7c765b7b8e60f1591ed1049bc2dc3143db779eae4838b89d195"
12
13RDEPENDS_${PN} = "man"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D}
20}
21
22# Only deliveres man-pages so FILES_${PN} gets everything
23FILES_${PN}-doc = ""
24FILES_${PN} = "${mandir}/*"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
30ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
31ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"