blob: e0eb994e2594aa6e1569e91292fa2e436473d1bc [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3 from glib-based software and produce a set of html documentation files from them"
4HOMEPAGE = "http://www.gtk.org/gtk-doc/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
18PACKAGECONFIG[working-scripts] = "--with-highlight=source-highlight,--with-highlight=no,libxslt-native xmlto-native source-highlight-native perl-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060020
21# We cannot use host perl, because it may be too old for gtk-doc
22EXTRANATIVEPATH += "perl-native"
23
24SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
25 file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
26 file://0001-Do-not-error-out-if-perl-is-not-found-or-its-version.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050027 file://conditionaltests.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028 "
29SRC_URI_append_class-native = " file://pkg-config-native.patch"
30
31SRC_URI[archive.md5sum] = "0dc6570953112a464a409fb99258ccbc"
32SRC_URI[archive.sha256sum] = "1ea46ed400e6501f975acaafea31479cea8f32f911dca4dff036f59e6464fd42"
33
Brad Bishop6e60e8b2018-02-01 10:27:11 -050034BBCLASSEXTEND = "native nativesdk"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035
36# Do not check for XML catalogs when building because that
37# information is not used for anything during build. Recipe
38# dependencies make sure we have all the right bits.
39do_configure_prepend() {
40 sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
41}
42
43FILES_${PN} += "${datadir}/sgml"
44FILES_${PN}-dev += "${libdir}/cmake"
45FILES_${PN}-doc = ""
46
47SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
48gtkdoc_makefiles_sysroot_preprocess() {
49 # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
50 # instead of libtool wrapper or running them directly
51 sed -i \
52 -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
53 ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
54}