blob: 4f91b76acf6f38d753c9bc15b298840a5b0b1b61 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "http://git.gnome.org/browse/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0 intltool-native"
11
12SRC_URI[archive.md5sum] = "6989b20cf3b26dd5ae272e04a9acb0b3"
13SRC_URI[archive.sha256sum] = "8f8a340d3ba99bfdef38b653da929652ea6640e27969d29f7ac51fbbe11a4346"
14
15PACKAGECONFIG ??= "ca-certificates gnutls"
16
17# No explicit dependency as it works without ca-certificates installed
18PACKAGECONFIG[ca-certificates] = "--with-ca-certificates=${sysconfdir}/ssl/certs/ca-certificates.crt,--without-ca-certificates"
19PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
20PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy"
21PACKAGECONFIG[pkcs11] = "--with-pkcs11,--without-pkcs11,p11-kit"
22
23EXTRA_OECONF = "--without-gnome-proxy"
24
25inherit gnomebase gettext
26
27FILES_${PN} += "${libdir}/gio/modules/libgio*.so ${datadir}/dbus-1/services/"
28FILES_${PN}-dbg += "${libdir}/gio/modules/.debug/"
29FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
30FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"