Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Asynchronous I/O library" |
| 2 | DESCRIPTION = "Asynchronous input/output library that uses the kernels native interface" |
| 3 | HOMEPAGE = "http://lse.sourceforge.net/io/aio.html" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499" |
| 7 | |
| 8 | SRC_URI = "${DEBIAN_MIRROR}/main/liba/libaio/libaio_${PV}.orig.tar.gz \ |
| 9 | file://generic-arch-dectection-for-padding-defines.patch \ |
| 10 | file://00_arches.patch \ |
| 11 | file://destdir.patch \ |
| 12 | file://libaio_fix_for_x32.patch \ |
| 13 | file://libaio_fix_for_mips_syscalls.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "2a35602e43778383e2f4907a4ca39ab8" |
| 17 | SRC_URI[sha256sum] = "e019028e631725729376250e32b473012f7cb68e1f7275bfc1bbcdd0f8745f7e" |
| 18 | |
| 19 | EXTRA_OEMAKE =+ "prefix=${prefix} includedir=${includedir} libdir=${libdir}" |
| 20 | # Need libc for stack-protector's __stack_chk_fail_local() bounce function |
| 21 | LDFLAGS_append_x86 = " -lc" |
| 22 | |
| 23 | do_configure () { |
| 24 | sed -i 's#LINK_FLAGS=.*#LINK_FLAGS=$(LDFLAGS)#' src/Makefile |
| 25 | } |
| 26 | |
| 27 | do_install () { |
| 28 | oe_runmake install DESTDIR=${D} |
| 29 | } |