blob: 06df384c7e96d754501c15486a514ad7dd61b7d7 [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
Brad Bishop75f03872018-11-03 09:41:57 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05007DEPENDS += "systemd"
Matt Spinler017f9422020-03-13 15:57:29 -05008DEPENDS += "${PYTHON_PN}-mako-native"
9DEPENDS += "${PYTHON_PN}-pyyaml-native"
10DEPENDS += "${PYTHON_PN}-native"
Patrick Williams4b32c9a2020-03-31 16:43:15 -050011DEPENDS += "${PYTHON_PN}-sdbus++-native"
12DEPENDS += "sdbusplus"
Patrick Williamsadd93832020-06-10 06:52:05 -050013DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050014DEPENDS += "virtual/phosphor-logging-callouts"
Brad Bishop17c08bf2018-10-18 17:07:53 -040015DEPENDS += "libcereal"
Matt Spinlerf319ea62019-07-23 16:04:04 -050016DEPENDS += "sdeventplus"
Patrick Williams60c49072021-04-16 14:14:26 -050017DEPENDS += "packagegroup-obmc-yaml-providers"
Andrew Geissler5803cd72023-01-24 16:20:19 -060018DEPENDS += "dbus"
devenraod81c93d2024-03-20 13:46:16 +053019SRCREV = "4fdb31aa910591c554b027b5213c2fc5adc4a382"
Patrick Williams2d52a382021-04-30 10:27:59 -050020PACKAGECONFIG ??= ""
Matt Spinlerf8510922019-08-08 13:21:24 -050021PACKAGECONFIG[openpower-pels] = " \
Patrick Williams2d52a382021-04-30 10:27:59 -050022 -Dopenpower-pel-extension=enabled, \
23 -Dopenpower-pel-extension=disabled, \
Manojkiran Edac5934752022-09-27 13:59:35 -050024 nlohmann-json cli11 libpldm python3, \
Harisuddin Mohamed Isacdfe38f2020-06-05 16:47:37 +080025 python3, \
Matt Spinlerf8510922019-08-08 13:21:24 -050026 "
Ed Tanous9936f862022-09-19 09:13:20 -070027PV = "1.0+git${SRCPV}"
28PR = "r1"
29
Patrick Williamsbccaff32023-04-14 11:24:47 -050030SRC_URI = "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070031
32SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
33S = "${WORKDIR}/git"
34
35inherit pkgconfig meson
36inherit python3native
37inherit obmc-phosphor-dbus-service
38inherit phosphor-logging
39inherit phosphor-dbus-yaml
Matt Spinlerf8510922019-08-08 13:21:24 -050040
Tim Lee55066862023-07-24 10:58:00 +080041def get_info_cap(d):
Jason M. Bills8b167cd2023-08-01 08:57:20 -070042 flash_size = int(d.getVar('FLASH_SIZE') or 0)
Tim Lee55066862023-07-24 10:58:00 +080043 if flash_size <= 32768:
44 return "10"
45 elif flash_size <= 65536:
46 return "128"
47 else:
48 return "256"
49
50ERR_INFO_CAP ??= "${@get_info_cap(d)}"
51ERR_INFO_CAP:df-phosphor-mmc ?= "256"
52
Patrick Williams2d52a382021-04-30 10:27:59 -050053EXTRA_OEMESON = " \
William A. Kennington IIIefe03c32021-05-29 14:55:41 -070054 -Dtests=disabled \
Patrick Williams2d52a382021-04-30 10:27:59 -050055 -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
56 -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
Tim Lee55066862023-07-24 10:58:00 +080057 -Derror_info_cap=${ERR_INFO_CAP} \
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050058 "
Ed Tanous9936f862022-09-19 09:13:20 -070059
60FILES:${PN}-test = "${bindir}/*-test"
61FILES:${PN}-base += " \
62 ${datadir}/dbus-1 \
63 ${bindir}/phosphor-log-manager \
64 ${libdir}/libphosphor_logging.so.* \
Andrew Geissler5803cd72023-01-24 16:20:19 -060065 ${datadir}/dbus-1/system-services/xyz.openbmc_project.Logging.service \
Ed Tanous9936f862022-09-19 09:13:20 -070066"
67FILES:phosphor-rsyslog-config += " \
68 ${bindir}/phosphor-rsyslog-conf \
69"
70
71ALLOW_EMPTY:${PN} = "1"
72
73USERADD_PACKAGES = "${PN}-base"
74
75PACKAGE_BEFORE_PN = "${PN}-test"
76# Package configuration
77LOGGING_PACKAGES = " \
78 ${PN}-base \
79 phosphor-rsyslog-config \
80"
81PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
82DBUS_PACKAGES = "${LOGGING_PACKAGES}"
83GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
84DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
85DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"