blob: 5ce093007136ab1b5c1d239c5163e5136e37ec05 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001DESCRIPTION = "This is a cross development C compiler, assembler and linker environment for the production of 8086 executables (Optionally MSDOS COM)"
2HOMEPAGE = "http://www.acpica.org/"
3LICENSE = "Intel-ACPI"
4LIC_FILES_CHKSUM = "file://asldefine.h;endline=115;md5=d4d7cf809b8b5e03131327b3f718e8f0"
5SECTION = "console/tools"
6PR="r1"
7
8DEPENDS="flex bison"
9
10SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "324c89e5bb9002e2711e0494290ceacc"
13SRC_URI[sha256sum] = "b2b497415f29ddbefe7be8b9429b62c1f1f6e1ec11456928e4e7da86578e5b8d"
14
15S="${WORKDIR}/acpica-unix-${PV}/source/compiler"
16
17NATIVE_INSTALL_WORKS = "1"
18BBCLASSEXTEND = "native"
19
20do_compile() {
21 CFLAGS="-Wno-error=redundant-decls" $MAKE
22}
23
24do_install() {
25 mkdir -p ${D}${prefix}/bin
26 cp ${S}/iasl ${D}${prefix}/bin
27}
28
29