blob: e2eb258d0b0b6948c8ff4ec5aa1d4c4e8909f9eb [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "05b112bda7ac2adba8e9b0f088d6e5843b148a38"
11PV = "2.3.1+git${SRCPV}"
12
Brad Bishopd89cb5f2019-04-10 09:02:41 -040013SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14 file://0001-utils-Ensure-stdout-stderr-are-flushed.patch \
15 file://0002-use-process-groups-when-spawning.patch \
16 file://0003-utils-Ensure-pipes-are-read-after-exit.patch"
17
Brad Bishop19323692019-04-05 15:28:33 -040018S = "${WORKDIR}/git"
19
20FILES_${PN} = "${bindir}/ptest-runner"
21
22EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
23
24do_compile () {
25 oe_runmake
26}
27
28do_install () {
29 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
30}