blob: 11b0065a6d11413e24c124201ca63ae18652d312 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001do_install() {
2 oe_runmake install_root=${D} install
3 for r in ${rpcsvc}; do
4 h=`echo $r|sed -e's,\.x$,.h,'`
5 install -m 0644 ${S}/sunrpc/rpcsvc/$h ${D}/${includedir}/rpcsvc/
6 done
Patrick Williamsc0f7c042017-02-23 20:41:17 -06007 install -Dm 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/ld.so.conf
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008 install -d ${D}${localedir}
9 make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED"
10 # get rid of some broken files...
11 for i in ${GLIBC_BROKEN_LOCALES}; do
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012 sed -i "/$i/d" ${WORKDIR}/SUPPORTED
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013 done
14 rm -f ${D}${sysconfdir}/rpc
15 rm -rf ${D}${datadir}/zoneinfo
16 rm -rf ${D}${libexecdir}/getconf
17}
18
19def get_libc_fpu_setting(bb, d):
20 if d.getVar('TARGET_FPU', True) in [ 'soft', 'ppc-efd' ]:
21 return "--without-fp"
22 return ""
23
24python populate_packages_prepend () {
25 if d.getVar('DEBIAN_NAMES', True):
26 pkgs = d.getVar('PACKAGES', True).split()
27 bpn = d.getVar('BPN', True)
28 prefix = d.getVar('MLPREFIX', True) or ""
29 # Set the base package...
30 d.setVar('PKG_' + prefix + bpn, prefix + 'libc6')
31 libcprefix = prefix + bpn + '-'
32 for p in pkgs:
33 # And all the subpackages.
34 if p.startswith(libcprefix):
35 renamed = p.replace(bpn, 'libc6', 1)
36 d.setVar('PKG_' + p, renamed)
37 # For backward compatibility with old -dbg package
38 d.appendVar('RPROVIDES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
39 d.appendVar('RCONFLICTS_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
40 d.appendVar('RREPLACES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg')
41}