Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command" |
| 2 | HOMEPAGE = "http://man-db.nongnu.org/" |
| 3 | DESCRIPTION = "man-db is an implementation of the standard Unix documentation system accessed using the man command. It uses a Berkeley DB database in place of the traditional flat-text whatis databases." |
| 4 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later & GPL-3.0-or-later" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \ |
| 6 | file://docs/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://docs/COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \ |
| 11 | file://99_mandb \ |
| 12 | file://0001-man-Move-local-variable-declaration-to-function-scop.patch \ |
| 13 | file://man_db.conf-avoid-multilib-install-file-conflict.patch" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "cffa1ee4e974be78646c46508e6dd2f37e7c589aaab2938cc1064f058fef9f8d" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | DEPENDS = "libpipeline gdbm groff-native base-passwd" |
| 17 | RDEPENDS:${PN} += "base-passwd" |
| 18 | PACKAGE_WRITE_DEPS += "base-passwd" |
| 19 | |
| 20 | # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr' |
| 21 | USE_NLS:libc-musl = "no" |
| 22 | |
| 23 | inherit gettext pkgconfig autotools systemd |
| 24 | |
| 25 | EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_system_unitdir}" |
| 26 | EXTRA_AUTORECONF += "-I ${S}/gl/m4" |
| 27 | |
| 28 | PACKAGECONFIG[bzip2] = "--with-bzip2=bzip2,ac_cv_prog_have_bzip2='',bzip2" |
| 29 | PACKAGECONFIG[gzip] = "--with-gzip=gzip,ac_cv_prog_have_gzip='',gzip" |
| 30 | PACKAGECONFIG[lzip] = "--with-lzip=lzip,ac_cv_prog_have_lzip='',lzip" |
| 31 | PACKAGECONFIG[lzma] = "--with-lzma=lzma,ac_cv_prog_have_lzma='',xz" |
| 32 | PACKAGECONFIG[zstd] = "--with-zstd=zstd,ac_cv_prog_have_zstd='',zstd" |
| 33 | PACKAGECONFIG[xz] = "--with-xz=xz,ac_cv_prog_have_xz='',xz" |
| 34 | |
| 35 | do_install() { |
| 36 | autotools_do_install |
| 37 | |
| 38 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 39 | install -d ${D}/etc/default/volatiles |
| 40 | install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles |
| 41 | fi |
| 42 | } |
| 43 | |
| 44 | do_install:append:libc-musl() { |
| 45 | rm -f ${D}${libdir}/charset.alias |
| 46 | } |
| 47 | |
| 48 | FILES:${PN} += "${prefix}/lib/tmpfiles.d" |
| 49 | |
| 50 | FILES:${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so" |
| 51 | |
| 52 | RDEPENDS:${PN} += "groff" |
| 53 | RRECOMMENDS:${PN} += "less" |
| 54 | RPROVIDES:${PN} += " man" |
| 55 | |
| 56 | def compress_pkg(d): |
| 57 | if bb.utils.contains("INHERIT", "compress_doc", True, False, d): |
| 58 | compress = d.getVar("DOC_COMPRESS") |
| 59 | if compress == "gz": |
| 60 | return "gzip" |
| 61 | elif compress == "bz2": |
| 62 | return "bzip2" |
| 63 | elif compress == "xz": |
| 64 | return "xz" |
| 65 | return "" |
| 66 | |
| 67 | RDEPENDS:${PN} += "${@compress_pkg(d)}" |
| 68 | |
| 69 | SYSTEMD_SERVICE:${PN} = "man-db.timer man-db.service" |
| 70 | SYSTEMD_AUTO_ENABLE ?= "disable" |