blob: 37d5a035cf19ee52e70cfebfc3c567f6b2cb2567 [file] [log] [blame]
Eddie Jamesacd9d072022-01-24 15:42:34 -06001SUMMARY = "Enable Linux trace events"
2DESCRIPTION = "Enable Linux trace events based on a configuration file"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6RDEPENDS:${PN} = " \
7 ${@d.getVar('PREFERRED_PROVIDER_u-boot-fw-utils', True) or 'u-boot-fw-utils'} \
8 bash \
9"
10
11S = "${WORKDIR}"
12
13SRC_URI += " file://trace-enable"
14
15TRACE_EVENTS = ""
16
17FILES:${PN} += "${sysconfdir}/trace-events.conf"
18FILES:${PN} += "${libexecdir}/trace-enable"
19
20do_install:append() {
21 install -d ${D}${sysconfdir}
22 for event in ${TRACE_EVENTS}
23 do
24 echo ${event} >> ${D}${sysconfdir}/trace-events.conf
25 done
26 echo >> ${D}${sysconfdir}/trace-events.conf
27 chmod 0644 ${D}${sysconfdir}/trace-events.conf
28
29 install -d ${D}${libexecdir}
30 install -m 0755 ${WORKDIR}/trace-enable ${D}${libexecdir}
31}
32
33SYSTEMD_SERVICE:${PN} = "trace-enable.service"
34
35inherit obmc-phosphor-systemd