blob: dae1e39437959f07ae46c0eabc965929c82b55d7 [file] [log] [blame]
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05001DESCRIPTION = "Fast, simple object-to-object and broadcast signaling."
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=42cd19c88fc13d1307a4efd64ee90e4e"
4
5SRC_URI[sha256sum] = "923e5e2f69c155f2cc42dafbbd70e16e3fde24d2d4aa2ab72fbe386238892462"
6
7inherit pypi setuptools3 ptest
8
9SRC_URI += "file://run-ptest"
10
11RDEPENDS:${PN}-ptest += " \
12 ${PYTHON_PN}-pytest \
13"
14
15do_install_ptest() {
16 install -d ${D}${PTEST_PATH}/tests
17 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
18}