blob: bb6c1ee813429b2f0594b101dc8eca824ceac71e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Fastest Python implementation of JSON schema"
5HOMEPAGE = "https://github.com/seznam/python-fastjsonschema"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532"
8
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05009SRCREV = "98399bb4029b2d7020d8abd9770661a5b2c4f9f8"
Andrew Geissler595f6302022-01-24 19:11:47 +000010PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master"
11
12SRC_URI += "file://run-ptest"
13
14inherit ptest pypi setuptools3
15
16S = "${WORKDIR}/git"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN}-ptest += "\
24 python3-colorama \
25 python3-jsonschema \
26 python3-pylint \
27 python3-pytest \
28 python3-pytest-benchmark \
29 python3-pytest-cache \
30"
31RDEPENDS:${PN} += "\
32 python3-core \
33 python3-urllib3 \
34 python3-numbers \
35 python3-pickle \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050036 python3-json \
Andrew Geissler595f6302022-01-24 19:11:47 +000037 "
38
39BBCLASSEXTEND = "native nativesdk"