blob: c9cf33d0230a061f0a95bca4614a6fb2a54a275f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A simple, safe single expression evaluator library"
2HOMEPAGE = "https://pypi.org/project/simpleeval/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
5
6SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36"
7
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10BBCLASSEXTEND = "native nativesdk"
11
12SRC_URI += " \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050013 file://no-build.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000014 file://run-ptest \
15"
16
17RDEPENDS:${PN} += " \
18 ${PYTHON_PN}-math \
19"
20
21RDEPENDS:${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
Andrew Geissler595f6302022-01-24 19:11:47 +000025do_install_ptest() {
26 cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
27}