blob: d677075570eb864c6ad4f9fccfcd3c3e70b24537 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[sha256sum] = "40dc582ce1eec631c3df79420b187a6da276bbd68a4ec0a8f1f123ea616b97a2"
11
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
14RDEPENDS:${PN} = "\
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050015 python3-meld3 \
16 python3-io \
17 python3-xmlrpc \
18 python3-resource \
19 python3-setuptools \
20 python3-smtpd \
Andrew Geissler595f6302022-01-24 19:11:47 +000021"
22
23SRC_URI += "file://supervisord.conf \
24 file://supervisor.service \
25 "
26SYSTEMD_SERVICE:${PN} = "supervisor.service"
27
28do_install:append() {
29 install -d ${D}${sysconfdir}/supervisor
30 install -d ${D}${systemd_system_unitdir}
31
32 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
33 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
34}