blob: 85fc7e0b3faadcd1d427e6349a7de7a8d1132812 [file] [log] [blame]
Andrew Geisslercc589282020-09-18 13:34:40 -05001SUMMARY = "IBM's Software TPM 2.0"
2DESCRIPTION = "The software TPM 2.0 is targeted toward application development, \
3education, and virtualization. \
4\
5The intent is that an application can be developed using the software TPM. \
6The application should then run using a hardware TPM without changes. \
7Advantages of this approach: \
8* In contrast to a hardware TPM, it runs on many platforms and it's generally faster. \
9* Application software errors are easily reversed by simply removing the TPM state and starting over. \
10* Difficult crypto errors are quickly debugged by looking inside the TPM."
11HOMEPAGE = "http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
Andrew Geissler5199d832021-09-24 16:47:35 -050012LICENSE = "BSD-2-Clause"
Andrew Geisslercc589282020-09-18 13:34:40 -050013SECTION = "securty/tpm"
14LIC_FILES_CHKSUM = "file://../LICENSE;md5=1e023f61454ac828b4aa1bc4293f7d5f"
15
16DEPENDS = "openssl"
17
18SRC_URI = "https://sourceforge.net/projects/ibmswtpm2/files/ibmtpm${PV}.tar.gz \
19 file://tune-makefile.patch \
Andrew Geisslercc589282020-09-18 13:34:40 -050020 "
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050021SRC_URI[sha256sum] = "3cb642f871a17b23d50b046e5f95f449c2287415fc1e7aeb4bdbb8920dbcb38f"
William A. Kennington IIIee32beb2021-06-02 12:48:35 -070022
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050023UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/ibmswtpm2/files/"
Andrew Geisslercc589282020-09-18 13:34:40 -050024
25S = "${WORKDIR}/src"
26
Andrew Geissler8b139282021-03-05 15:22:30 -060027CFLAGS += "-Wno-error=maybe-uninitialized -DALG_CAMELLIA=ALG_NO"
Andrew Geisslercc589282020-09-18 13:34:40 -050028
29do_compile () {
30 make CC='${CC}'
31}
32
33do_install () {
34 install -d ${D}/${bindir}
35 install -m 0755 tpm_server ${D}/${bindir}
36}