blob: 4c1b8eed5664c8f0025f49629bb489409023c99a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ad93ca1fffe931537fcf64f6fcce084d"
7
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008SRCREV = "0c1fa696aa502eb749c2c4735005f41ba00a27b8"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI = "git://github.com/libuv/libuv;branch=v1.x;protocol=https"
10UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16do_configure() {
17 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
18 oe_runconf
19}
20
21BBCLASSEXTEND = "native"