blob: 5b24bef5cdac2db4c8893f5fe1764fc2da23883a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPL-2.0-only & LGPL-2.1-or-later"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \
14"
15SECTION = "base"
Andrew Geissler78b72792022-06-14 06:47:25 -050016DEPENDS = "util-linux zlib"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git;branch=master \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050020 file://0001-device-utils.c-Use-linux-mount.h-instead-of-sys-moun.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000021 "
Andrew Geissler615f2f12022-07-15 14:00:58 -050022SRCREV = "47b5cf867fc37411ef51eb5c09893a95f7f6c3b7"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= " \
26 programs \
27 convert \
28 python \
29 crypto-builtin \
30"
Andrew Geissler78b72792022-06-14 06:47:25 -050031PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, python3-sphinx-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +000032PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
33PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
34PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned"
35PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
Andrew Geissler78b72792022-06-14 06:47:25 -050036PACKAGECONFIG[lzo] = "--enable-lzo,--disable-lzo,lzo"
Andrew Geissler9aee5002022-03-30 16:27:02 +000037PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
38PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev"
39
40# Pick only one crypto provider
41PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
42PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
43PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
44PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
45
46inherit autotools-brokensep pkgconfig manpages
47inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3-base', '', d)}
48
49CLEANBROKEN = "1"
50
51EXTRA_OECONF = "--enable-largefile"
52EXTRA_OECONF:append:libc-musl = " --disable-backtrace "
53EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
54EXTRA_PYTHON_CFLAGS:class-native = ""
55EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
56EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
57
58do_configure:prepend() {
59 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
60 mkdir -p ${S}/config
61 cp -f $(automake --print-libdir)/install-sh ${S}/config/
62}
63
64
65do_install:append() {
66 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
67 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
68 fi
69}
70
71RDEPENDS:${PN} = "libgcc"
72
73BBCLASSEXTEND = "native nativesdk"