blob: 9efdae8ad5aaf74d4aab74181d494c00e52800a1 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "ALSA sound library"
2DESCRIPTION = "(Occasionally a.k.a. libasound) is a userspace library that \
3provides a level of abstraction over the /dev interfaces provided by the kernel modules."
4HOMEPAGE = "http://www.alsa-project.org"
5BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
6SECTION = "libs/multimedia"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "LGPL-2.1-only & GPL-2.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
9 file://src/socket.c;md5=285675b45e83f571c6a957fe4ab79c93;beginline=9;endline=24 \
10 "
11
12SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050013SRC_URI[sha256sum] = "8a35b7218e50f2a2c79342d0de98ded81439ce19e12809385ec9be9596de7c2f"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15inherit autotools pkgconfig
16
17EXTRA_OECONF += " \
18 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-softfloat', '', d)} \
19 --disable-python \
20"
21
22PACKAGES =+ "alsa-server alsa-conf libatopology"
23
24FILES:alsa-server = "${bindir}/*"
25FILES:alsa-conf = "${datadir}/alsa/"
26FILES:libatopology = "${libdir}/libatopology.so.*"
27
28RDEPENDS:${PN}:class-target = "alsa-conf alsa-ucm-conf"
29RDEPENDS:libatopology:class-target = "alsa-topology-conf"
30
31# upgrade path
32RPROVIDES:${PN} = "libasound"
33RREPLACES:${PN} = "libasound"
34RCONFLICTS:${PN} = "libasound"
35
36RPROVIDES:${PN}-dev = "alsa-dev"
37RREPLACES:${PN}-dev = "alsa-dev"
38RCONFLICTS:${PN}-dev = "alsa-dev"
39
40RPROVIDES:alsa-conf = "alsa-conf-base"
41RREPLACES:alsa-conf = "alsa-conf-base"
42RCONFLICTS:alsa-conf = "alsa-conf-base"
43
44BBCLASSEXTEND = "native nativesdk"