blob: 502d9d114cf30ef49ced1cb8d703c7fabc1c9ba9 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000010LIC_FILES_CHKSUM = "file://COPYING;md5=e7b9c15fcfb986abb4cc5e8400a24169"
11
12SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050013SRC_URI[sha256sum] = "1b20c9c751bea9be556749bd7f97cf580f52ed11f2540756e9af26ae036e4c59"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15UPSTREAM_CHECK_REGEX = "mpg123-(?P<pver>\d+(\.\d+)+)\.tar"
16
17inherit autotools pkgconfig
18
19# The options should be mutually exclusive for configuration script.
20# If both alsa and pulseaudio are specified (as in the default distro features)
21# pulseaudio takes precedence.
22PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
23PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
24
25PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
26PACKAGECONFIG[esd] = ",,esound"
27PACKAGECONFIG[jack] = ",,jack"
28PACKAGECONFIG[openal] = ",,openal-soft"
29PACKAGECONFIG[portaudio] = ",,portaudio-v19"
30PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
31PACKAGECONFIG[sdl] = ",,libsdl2"
32
33# Following are possible sound output modules:
34# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
35AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
36AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
37
38EXTRA_OECONF = " \
39 --enable-shared \
40 --with-audio='${AUDIOMODS}' \
41 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
42 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
43 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-cpu=generic_nofpu', '', d)} \
44"
45# Fails to build with thumb-1 (qemuarm)
46#| {standard input}: Assembler messages:
47#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
48#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
49#...
50#| make[3]: *** [equalizer.lo] Error 1
51ARM_INSTRUCTION_SET:armv4 = "arm"
52ARM_INSTRUCTION_SET:armv5 = "arm"