Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Bellagio OpenMAX Integration Layer (IL)" |
| 2 | DESCRIPTION = "Bellagio is an opensource implementation of the Khronos OpenMAX \ |
| 3 | Integration Layer API to access multimedia components." |
| 4 | HOMEPAGE = "http://omxil.sourceforge.net/" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1+" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 7 | LICENSE_FLAGS = "${@bb.utils.contains('PACKAGECONFIG', 'amr', 'commercial', '', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ae6f0f4dbc7ac193b50f323a6ae191cb \ |
| 9 | file://src/omxcore.h;beginline=1;endline=27;md5=806b1e5566c06486fe8e42b461e03a90" |
| 10 | |
| 11 | SRC_URI = "${SOURCEFORGE_MIRROR}/omxil/libomxil-bellagio-${PV}.tar.gz \ |
| 12 | file://configure-fix.patch \ |
| 13 | file://parallel-make.patch \ |
| 14 | file://makefile-docdir-fix.patch \ |
| 15 | file://dynamicloader-linking.patch \ |
| 16 | file://disable-so-versioning.patch" |
| 17 | |
| 18 | SRC_URI[md5sum] = "a1de827fdb75c02c84e55f740ca27cb8" |
| 19 | SRC_URI[sha256sum] = "593c0729c8ef8c1467b3bfefcf355ec19a46dd92e31bfc280e17d96b0934d74c" |
| 20 | |
| 21 | S = "${WORKDIR}/${BPN}-bellagio-${PV}" |
| 22 | |
| 23 | inherit autotools |
| 24 | |
| 25 | EXTRA_OECONF += "--disable-doc --disable-Werror" |
| 26 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | PROVIDES += "virtual/libomxil" |
| 28 | |
Andrew Geissler | 635e0e4 | 2020-08-21 15:58:33 -0500 | [diff] [blame] | 29 | CFLAGS += "-fcommon" |
| 30 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 31 | PACKAGECONFIG ??= "" |
| 32 | |
| 33 | PACKAGECONFIG[amr] = "--enable-amr,," |
| 34 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 35 | # |
| 36 | # The .so files under ${libdir}/bellagio are not intended to be versioned and symlinked. |
| 37 | # Make sure they get packaged in the main package. |
| 38 | # |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:${PN} += "${libdir}/bellagio/*.so \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 40 | ${libdir}/omxloaders/*${SOLIBS}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | FILES:${PN}-staticdev += "${libdir}/bellagio/*.a \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | ${libdir}/omxloaders/*.a" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN}-dev += "${libdir}/bellagio/*.la \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 44 | ${libdir}/omxloaders/*.la \ |
| 45 | ${libdir}/omxloaders/*${SOLIBSDEV}" |