blob: fdd8a76cfe10df8b7f9b87978a38b713cdb6b389 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Supervisor: A Process Control System"
2DESCRIPTION = "\
3Supervisor is a client/server system that allows its users \
4to monitorand control a number of processes on UNIX-like \
5operating systems."
6HOMEPAGE = "https://github.com/Supervisor/supervisor"
7LICENSE = "BSD-4-Clause"
8LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=5b4e3a2172bba4c47cded5885e7e507e"
9
10SRC_URI[sha256sum] = "40dc582ce1eec631c3df79420b187a6da276bbd68a4ec0a8f1f123ea616b97a2"
11
12PYPI_PACKAGE = "supervisor"
13inherit pypi systemd setuptools3
14RDEPENDS:${PN} = "\
15 ${PYTHON_PN}-meld3 \
16"
17
18SRC_URI += "file://supervisord.conf \
19 file://supervisor.service \
20 "
21SYSTEMD_SERVICE:${PN} = "supervisor.service"
22
23do_install:append() {
24 install -d ${D}${sysconfdir}/supervisor
25 install -d ${D}${systemd_system_unitdir}
26
27 install -m 0644 ${WORKDIR}/supervisord.conf ${D}${sysconfdir}/supervisor
28 install -m 0644 ${WORKDIR}/supervisor.service ${D}${systemd_system_unitdir}
29}