Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | LICENSE = "LGPLv2.1 & GPLv2" |
| 2 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 3 | file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | |
| 5 | SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \ |
| 6 | " |
| 7 | |
| 8 | SRC_URI_append_libc-musl = " \ |
| 9 | file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \ |
| 10 | file://0002-musl-does-not-provide-printf-h.patch \ |
| 11 | file://0003-musl-does-not-provide-canonicalize_file_name.patch \ |
| 12 | " |
| 13 | |
| 14 | |
| 15 | # Modify these as desired |
| 16 | PV = "233+git${SRCPV}" |
| 17 | SRCREV = "fe1c5e41e6bdb78043dad8fa863fc2df66d1dadf" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool" |
| 22 | |
| 23 | inherit pkgconfig autotools systemd distro_features_check |
| 24 | |
| 25 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service" |
| 28 | |
| 29 | do_configure_prepend() { |
| 30 | # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot |
| 31 | rm -f ${S}/m4/intltool.m4 |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${systemd_unitdir}/systemd-bootchart" |
| 35 | |
| 36 | EXTRA_OECONF = " --with-rootprefix=${base_prefix} \ |
| 37 | --with-rootlibdir=${base_libdir}" |