Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "XFt: X FreeType libary" |
| 2 | |
| 3 | DESCRIPTION = "Xft was designed to provide good support for scalable \ |
| 4 | fonts, and to do so efficiently. Unlike the core fonts system, it \ |
| 5 | supports features such as anti-aliasing and sub-pixel rasterisation. \ |
| 6 | Perhaps more importantly, it gives applications full control over the \ |
| 7 | way glyphs are rendered, making fine typesetting and WYSIWIG display \ |
| 8 | possible. Finally, it allows applications to use fonts that are not \ |
| 9 | installed system-wide for displaying documents with embedded fonts. Xft \ |
| 10 | is not compatible with the core fonts system: usage of Xft requires \ |
| 11 | fairly extensive changes to toolkits (user-interface libraries)." |
| 12 | |
| 13 | require xorg-lib-common.inc |
| 14 | |
| 15 | LICENSE = "MIT" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=90b90b60eb30f65fc9c2673d7cf59e24" |
| 17 | |
| 18 | DEPENDS += "virtual/libx11 libxrender freetype fontconfig" |
| 19 | PROVIDES = "xft" |
| 20 | |
| 21 | PE = "1" |
| 22 | |
| 23 | SRC_URI[md5sum] = "331b3a2a3a1a78b5b44cfbd43f86fcfe" |
| 24 | SRC_URI[sha256sum] = "f5a3c824761df351ca91827ac221090943ef28b248573486050de89f4bfcdc4c" |
| 25 | |
| 26 | XORG_PN = "libXft" |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |
| 29 | |
| 30 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | if d.getVar('DEBIAN_NAMES'): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | d.setVar('PKG_${PN}', '${MLPREFIX}libxft2') |
| 33 | } |