blob: 13a1b919ed21ab61180053c8407b7d2f4aeb67ff [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001require xorg-lib-common.inc
2
3# libxpm requires xgettext to build
4inherit gettext
5
6SUMMARY = "Xpm: X Pixmap extension library"
7
8DESCRIPTION = "libXpm provides support and common operation for the XPM \
9pixmap format, which is commonly used in legacy X applications. XPM is \
10an extension of the monochrome XBM bitmap specificied in the X \
11protocol."
12
13LICENSE = "BSD"
14LIC_FILES_CHKSUM = "file://COPYING;md5=51f4270b012ecd4ab1a164f5f4ed6cf7"
15DEPENDS += "libxext libsm libxt"
16PE = "1"
17
18XORG_PN = "libXpm"
19
20PACKAGES =+ "sxpm cxpm"
21FILES_cxpm = "${bindir}/cxpm"
22FILES_sxpm = "${bindir}/sxpm"
23
24SRC_URI[md5sum] = "20f4627672edb2bd06a749f11aa97302"
25SRC_URI[sha256sum] = "fd6a6de3da48de8d1bb738ab6be4ad67f7cb0986c39bd3f7d51dd24f7854bdec"
26
27BBCLASSEXTEND = "native"