blob: 1440d727118359eb816a609e624b6329cfd3b15c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# Copyright (c) 2012-2014 LG Electronics, Inc.
2SUMMARY = "c-ares is a C library that resolves names asynchronously."
3HOMEPAGE = "http://daniel.haxx.se/projects/c-ares/"
4SECTION = "libs"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006"
7
8SRC_URI = "git://github.com/c-ares/c-ares.git;branch=main;protocol=https"
Patrick Williamse760df82023-05-26 11:10:49 -05009SRCREV = "6360e96b5cf8e5980c887ce58ef727e53d77243a"
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig
16
17PACKAGES =+ "${PN}-utils"
18
19FILES:${PN}-utils = "${bindir}"
20
21BBCLASSEXTEND = "native nativesdk"