blob: 19e256c0707c84a947240eb15c35f90086c366d6 [file] [log] [blame]
Brad Bishop69eac0b2020-08-10 18:13:26 -04001DESCRIPTION = "Image with Phosphor, a software stack for hardware management \
2in devices with baseboard management controllers. The image supports the \
3full OpenBMC feature set for devices of all types."
Ed Tanous9936f862022-09-19 09:13:20 -07004LICENSE = "Apache-2.0"
5
6inherit obmc-phosphor-image
7
8# The /etc/version file is misleading and not useful. Remove it.
9# Users should instead rely on /etc/os-release.
10ROOTFS_POSTPROCESS_COMMAND += "remove_etc_version ; "
Brad Bishop93fb5352015-09-09 03:59:20 +000011
Brad Bishop0c434cc2018-12-05 07:03:22 -050012IMAGE_LINGUAS = ""
Brad Bishop3132c982020-08-10 19:18:57 -040013IMAGE_FEATURES += " \
14 obmc-bmc-state-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -040015 obmc-bmcweb \
Brad Bishop3132c982020-08-10 19:18:57 -040016 obmc-chassis-mgmt \
17 obmc-chassis-state-mgmt \
Brad Bishop8c09b142020-08-11 08:20:31 -040018 obmc-console \
Brad Bishope3fe5782020-08-10 20:20:47 -040019 obmc-devtools \
Brad Bishop3132c982020-08-10 19:18:57 -040020 obmc-fan-control \
21 obmc-fan-mgmt \
22 obmc-flash-mgmt \
Brad Bishopc1371fd2020-08-18 19:30:11 -040023 obmc-fru-ipmi \
Vijay Khemkad549dee2020-09-08 11:56:19 -070024 obmc-health-monitor \
Brad Bishop3132c982020-08-10 19:18:57 -040025 obmc-host-ctl \
26 obmc-host-ipmi \
27 obmc-host-state-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -040028 obmc-ikvm \
Brad Bishop3132c982020-08-10 19:18:57 -040029 obmc-inventory \
30 obmc-leds \
31 obmc-logging-mgmt \
32 obmc-remote-logging-mgmt \
Brad Bishop8c09b142020-08-11 08:20:31 -040033 obmc-rng \
Brad Bishop3132c982020-08-10 19:18:57 -040034 obmc-net-ipmi \
35 obmc-sensors \
36 obmc-software \
Patrick Williams5a5f33c2021-11-03 10:35:37 -050037 obmc-system-mgmt \
Brad Bishop3132c982020-08-10 19:18:57 -040038 obmc-user-mgmt \
Brad Bishopb52116a2020-08-10 20:45:15 -040039 obmc-user-mgmt-ldap \
Patrick Williams9b52fdc2023-02-03 17:27:34 -060040 ${@bb.utils.contains_any('DISTRO_FEATURES', \
41 'obmc-ubi-fs phosphor-mmc obmc-static-norootfs', \
Patrick Williamsa0e20ab2023-05-05 16:31:59 -050042 'read-only-rootfs overlayfs-etc', '', d)} \
Brad Bishop3132c982020-08-10 19:18:57 -040043 ssh-server-dropbear \
44 obmc-debug-collector \
45 obmc-network-mgmt \
46 obmc-settings-mgmt \
Wludzik, Jozefe9defc02021-01-28 09:36:34 +010047 obmc-telemetry \
Rashmica Guptaddaca3c2023-02-01 15:26:58 +110048 obmc-dmtf-pmci \
Brad Bishop3132c982020-08-10 19:18:57 -040049 "
Brad Bishop4041ba52020-08-10 19:58:36 -040050# The shadow recipe provides the binaries(like useradd, usermod) needed by the
51# phosphor-user-manager.
Patrick Williams12fc9392021-08-06 09:16:53 -050052ROOTFS_RO_UNNEEDED:remove = "shadow"
Patrick Williamsa0e20ab2023-05-05 16:31:59 -050053
54# We need to set overlayfs-etc so that the dropbear/openssh keys don't end up
55# in a volatile file system, but we always have our own init that sets these
56# up. Add enough bogus values here that rootfs-postcommands.bbclass does what
57# we want without overlayfs-etc.bbclass messing things up.
58OVERLAYFS_ETC_USE_ORIG_INIT_NAME="0"
59OVERLAYFS_ETC_MOUNT_POINT = "/this/is/unused"
60OVERLAYFS_ETC_FSTYPE = "not_a_fs_type"
61OVERLAYFS_ETC_DEVICE = "/dev/null"
62python create_overlayfs_etc_preinit:append() {
63 os.unlink(preinitPath)
64}