blob: 0e93790855a88094da6a54cedacb881882a01417 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
7LICENSE = "GPLv2+"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
10
11DEPENDS = "popt util-linux"
12
13SRC_URI = "https://github.com/rhinstaller/${BPN}/archive/${PV}-1.tar.gz;downloadfilename=${BPN}-${PV}-1.tar.gz \
14 file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
15 file://run-ptest \
16"
17
18SRC_URI[md5sum] = "1005907b275d6d93368d045274537d86"
19SRC_URI[sha256sum] = "85f1c678484f74c8978e8643451594967defce463a86c35cb1ee56d12767a9df"
20
21S = "${WORKDIR}/${BPN}-${PV}-1"
22
23RDEPENDS_${PN} += "dracut"
24
25inherit autotools-brokensep ptest
26
27EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}'"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}
31 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
32 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
33}
34
35RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
36
37COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'