blob: fdf54e3b1f795e2193a5fadff44789217207fb23 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "System performance benchmark"
2HOMEPAGE = "http://github.com/akopytov/sysbench"
3SECTION = "console/tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7inherit autotools
8
9# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
10# Launchpad until the next release is available from Github.
11SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz"
12
13SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
14SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"
15
16PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)}"
17PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
18PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
19PACKAGECONFIG[mysql] = "--with-mysql \
20 --with-mysql-includes=${STAGING_INCDIR}/mysql \
21 --with-mysql-libs=${STAGING_LIBDIR}, \
22 --without-mysql,mysql5"
23
24do_configure_prepend() {
25 touch ${S}/NEWS ${S}/AUTHORS
26}