blob: 40fb96cf47bb8426a40825ead79214a88a058441 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11
12DEPENDS = "protobuf-native protobuf"
13
14PACKAGE_BEFORE_PN = "${PN}-compiler"
15RDEPENDS_${PN}-compiler = "protobuf-compiler"
16RDEPENDS_${PN}-dev += "${PN}-compiler"
17
18LIC_FILES_CHKSUM = "file://LICENSE;md5=235c3195a3968524dc1524b4ebea0c0e"
19SRC_URI = "https://github.com/protobuf-c/protobuf-c/archive/v${PV}.tar.gz"
20
21SRC_URI[md5sum] = "b884aeba4283309445a8e3b6e7322dd6"
22SRC_URI[sha256sum] = "2d708fb3c024b9e6e86df141faff802194f5db90a4b79e6d4aa6bd61dd983dd6"
23
24inherit autotools pkgconfig
25
26FILES_${PN}-compiler = "${bindir}"
27
28BBCLASSEXTEND = "native nativesdk"