blob: 55d366e2e8fe91b00397d5a27ffe16487d7a7f8a [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Control and monitor storage systems using S.M.A.R.T"
2DESCRIPTION = \
3"The smartmontools package contains two utility programs (smartctl \
4and smartd) to control and monitor storage systems using the Self-\
5Monitoring, Analysis and Reporting Technology System (SMART) built \
6into most modern ATA and SCSI hard disks. In many cases, these \
7utilities will provide advanced warning of disk degradation and failure."
8
9HOMEPAGE = "http://smartmontools.sourceforge.net/"
10SECTION = "console/utils"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \
16 file://initd.smartd \
17 file://smartmontools.default \
18 file://smartd.service \
19"
20
21PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'libcap-ng', 'libcap-ng', '', d)} \
22 ${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
23"
24PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng"
25PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux"
26
27SRC_URI[md5sum] = "093aeec3f8f39fa9a37593c4012d3156"
28SRC_URI[sha256sum] = "89e8bb080130bc6ce148573ba5bb91bfe30236b64b1b5bbca26515d4b5c945bc"
29
30inherit autotools update-rc.d systemd
31
32SYSTEMD_SERVICE_${PN} = "smartd.service"
33SYSTEMD_AUTO_ENABLE = "disable"
34
35do_install_append () {
36 #install the init.d/smartd
37 install -d ${D}${sysconfdir}/init.d
38 install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd
39 install -d ${D}${sysconfdir}/default
40 install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools
41
42 #install systemd service file
43 install -d ${D}${systemd_unitdir}/system
44 install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system
45 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
46 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
47 -e 's,@SBINDIR@,${sbindir},g' \
48 ${D}${systemd_unitdir}/system/smartd.service
49}
50
51INITSCRIPT_NAME = "smartd"
52INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ."
53
54RDEPENDS_${PN} += "mailx"