blob: f36cf4b182b520e7585fff77d671203255ef86e1 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001require ttf.inc
2
3SUMMARY = "Liberation(tm) Fonts"
4DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
5created by Ascender(c) which aims at metric compatibility with \
6Arial, Times New Roman, Courier New."
7
8HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11
12SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
13 file://30-0-liberation-sans-narrow.conf \
14"
15
16SRC_URI[md5sum] = "134d8262145fc793c6af494dcace3e71"
17SRC_URI[sha256sum] = "61a7e2b6742a43c73e8762cdfeaf6dfcf9abdd2cfa0b099a9854d69bc4cfee5c"
18
19S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
20
21do_install_append () {
22 install -d ${D}${datadir}/fonts/TTF/
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 LiberationSansNarrow*.ttf ${D}${datadir}/fonts/TTF/
25 install -D -m 0644 ${WORKDIR}/30-0-liberation-sans-narrow.conf ${D}${sysconfdir}/conf.avail/30-${PN}-sans.conf
26 install -D -m 0644 ${S}/License.txt ${D}${datadir}/licenses/${PN}/LICENSE
27}
28
29PACKAGES = "${PN}"
30FONT_PACKAGES = "${PN}"
31
32FILES_${PN} = "${datadir}/fonts ${sysconfdir} ${datadir}/licenses"