blob: c9a22703aacd3958ab3e4211825a21be1da585fa [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "VMcore extraction tool"
2DESCRIPTION = "\
3 This program is used to extract a subset of the memory available either \
4 via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \
5 images without extra uneeded information (zero pages, userspace programs, \
6 etc). \
7"
8HOMEPAGE = "http://makedumpfile.sourceforge.net"
9
10DEPENDS = "bzip2 zlib elfutils"
11RDEPENDS_${PN}-tools = "perl ${PN}"
12
13# arm would compile but has never been tested upstream. mips would not compile.
14#
15COMPATIBLE_HOST = "(x86_64|i.86|powerpc).*-linux"
16
17PACKAGES =+ "${PN}-tools"
18FILES_${PN}-tools = "${bindir}/*.pl"
19
20SRC_URI = "\
21 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \
22 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
23"
24LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
25LICENSE = "GPLv2.0"
26
27SRC_URI[md5sum] = "041c5c6de2c3066600e4ca646c2397d6"
28SRC_URI[sha256sum] = "e3147abc52df2ceac1e9affef45bf37e2f2e1d9979bc94a761ee11e4044072ac"
29
30SECTION = "base"
31
32# If we do not specify TARGET, makedumpfile will build for the host but use the
33# target gcc.
34#
35EXTRA_OEMAKE = "\
36 LINKTYPE=static \
37 TARGET=${TARGET_ARCH} \
38"
39
40do_install () {
41 mkdir -p ${D}/usr/bin
42 install -m 755 ${S}/makedumpfile ${D}/usr/bin
43 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin
44
45 mkdir -p ${D}/usr/share/man/man8
46 install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8
47
48 mkdir -p ${D}/usr/share/man/man5
49 install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5
50
51 mkdir -p ${D}/etc/
52 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample
53}