blob: 66cec0a7d624d29a754e57c7d1da7340961ccb2a [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
15DEPENDS = "libsamplerate0 libsndfile1 libopus readline"
16
17SRC_URI = "git://github.com/jackaudio/jack2.git"
18SRCREV = "364159f8212393442670b9c3b68b75aa39d98975"
19PV = "1.9.10+git${SRCPV}"
20S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ??= "alsa"
25PACKAGECONFIG[alsa] = "--alsa=yes,alsa=no,alsa-lib"
26
27# portaudio is for windows builds only
28EXTRA_OECONF = "--portaudio=no"
29
30PACKAGES =+ "libjack jack-server jack-utils"
31
32FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
33FILES_jack-server = "${bindir}/jackd"
34FILES_jack-utils = "${bindir}/*"
35FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "