blob: 092a6740d4b73dc6c535017c48dcb4613619fd64 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception"
4LIC_FILES_CHKSUM = "file://COPYING;md5=34197a479f637beb9e09e56893f48bc2"
5
6DEPENDS = "curl openssl zlib libssh2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v0.24"
9SRCREV = "211e117a0590583a720c53172406f34186c543bd"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DTHREADSAFE=ON \
17 -DBUILD_CLAR=OFF \
18 -DSHA1_TYPE="builtin" \
19 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
20 -DBUILD_EXAMPLES=OFF \
21"
22
23BBCLASSEXTEND = "native"