blob: d88006c366c3330704c1adbd4a8e90b52275c147 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Library for using PKCS"
2DESCRIPTION = "\
3Libp11 is a library implementing a small layer on top of PKCS \
4make using PKCS"
5HOMEPAGE = "http://www.opensc-project.org/libp11"
6SECTION = "Development/Libraries"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
9DEPENDS = "libtool openssl"
10
11SRC_URI = "git://github.com/OpenSC/libp11.git"
12SRCREV = "22de793340ab73cafc92f8238afb51a06d8411c3"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18# Currently, Makefile dependencies are incorrectly defined which causes build errors
19# The number of jobs is high
20# See https://github.com/OpenSC/libp11/issues/94
21PARALLEL_MAKE = ""
22EXTRA_OECONF = "--disable-static"
23
24do_install_append () {
25 rm -rf ${D}${libdir}/*.la
26 rm -rf ${D}${docdir}/${BPN}
27}
28
29FILES_${PN} += "${libdir}/pkcs11${SOLIBS}"
30FILES_${PN}-dev += "${libdir}/pkcs11${SOLIBSDEV}"