blob: 01708df35a06449664b796080e99dc52909f82f1 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Library for interfacing with common SoC peripherals"
2DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
3 found in SoC (System on Chips) through generic Linux Kernel interfaces."
4
5HOMEPAGE = "https://github.com/jackmitch/libsoc"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
9
10inherit autotools pkgconfig python-dir
11
12SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
13SRC_URI = "git://github.com/jackmitch/libsoc.git"
14
15S = "${WORKDIR}/git"
16
17BOARD ??= "devboard"
18
19PACKAGECONFIG ?= ""
20
21PACKAGECONFIG[disabledebug] = "--disable-debug,,"
22PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
23PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
24PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
25
26PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
27 '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
28
29RDEPENDS_${PN} = "libgcc"
30
31FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
32FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}"