blob: cb9aa22cfb98f1d85b9ecaa82222a01dc14ad7cd [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Pluggable password quality-control module."
2DESCRIPTION = "pam_passwdqc is a simple password strength checking module for \
3PAM-aware password changing programs, such as passwd(1). In addition \
4to checking regular passwords, it offers support for passphrases and \
5can provide randomly generated passwords. All features are optional \
6and can be (re-)configured without rebuilding."
7
8HOMEPAGE = "http://www.openwall.com/passwdqc/"
9SECTION = "System Environment/Base"
10
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=e284d013ef08e66d4737f446c5890550"
13
14SRC_URI = "http://www.openwall.com/pam/modules/pam_passwdqc/pam_passwdqc-1.0.5.tar.gz \
Patrick Williamsddad1a12017-02-23 20:36:32 -060015 file://1000patch-219201.patch \
16 file://7000Makefile-fix-CC.patch \
17"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018SRC_URI[md5sum] = "cd9c014f736158b1a60384a8e2bdc28a"
19SRC_URI[sha256sum] = "32528ddf7d8219c788b6e7702361611ff16c6340b6dc0f418ff164aadc4a4a88"
20
21
22S = "${WORKDIR}/pam_passwdqc-${PV}"
23
24DEPENDS = "libpam"
25
26EXTRA_OEMAKE = "CFLAGS="${CFLAGS} -Wall -fPIC -DHAVE_SHADOW" \
Patrick Williamsddad1a12017-02-23 20:36:32 -060027 SECUREDIR=${base_libdir}/security \
28"
29
30TARGET_CC_ARCH += "${LDFLAGS}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031
32do_install() {
Patrick Williamsddad1a12017-02-23 20:36:32 -060033 oe_runmake install DESTDIR=${D}
Patrick Williamsb48b7b42016-08-17 15:04:38 -050034}
35
36FILES_${PN} += "${base_libdir}/security/pam_passwdqc.so"
37FILES_${PN}-dbg += "${base_libdir}/security/.debug"
38