blob: aefe3627eba741511eefe371bec44b617aa51c12 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A filesystem snapshot utility based on rsync"
2HOMEPAGE = "http://www.rsnapshot.org"
3BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
8
9RDEPENDS_${PN} = "rsync \
10 perl \
11 perl-module-dirhandle \
12 perl-module-cwd \
13 perl-module-getopt-std \
14 perl-module-file-path \
15 perl-module-file-stat \
16 perl-module-posix \
17 perl-module-fcntl \
18 perl-module-io-file \
19 perl-module-constant \
20 perl-module-overloading \
21 "
22
Patrick Williamsddad1a12017-02-23 20:36:32 -060023SRCREV = "27209563f924a22f510698ea225f53ea52f07cb4"
24PV = "1.4.2+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025
26SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=git \
27 file://configure-fix-cmd_rsync.patch \
28 "
29
30S = "${WORKDIR}/git"
31
32inherit autotools
33
34# Fix rsnapshot.conf.default:
35# don't inject the host path into target configs.
36EXTRA_OECONF += "--without-cp \
37 --without-rm \
38 --without-du \
39 --without-ssh \
40 --without-logger \
41 --without-rsync \
42 ac_cv_path_PERL=${bindir}/perl \
Patrick Williamsddad1a12017-02-23 20:36:32 -060043 ac_cv_path_MOUNT=${base_bindir}/mount \
44 ac_cv_path_UMOUNT=${base_bindir}/umount \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060046
47# Create 't/include.ac' before starting the autoreconf to fix configure
48# error: configure.ac:302: file 't/include.ac' does not exist
49do_configure_prepend(){
50 saved_dir=`pwd`
51 cd ${S}; ./autogen.sh
52 cd ${saved_dir}
53}