blob: 271b559b77876ffefbf8827f924971ca1ef7f70a [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
6DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
12SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils-base autotools pkgconfig
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
19PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
20
21export STAGING_LIBDIR
22export STAGING_INCDIR
23
24RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
25
26FILES_${PN}-dev += "${libdir}/pkgconfig"
27
28do_install_append() {
29 # Remove files that clash with python3-dbus; their content is same
30 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
31}