blob: 60dd7d0a363f52c541841eaa836bec18a8a4a680 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Python Imaging Library (PIL)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://README;beginline=92;endline=120;md5=c4371af4579f1e489cf881c1443dd4ec"
5DEPENDS = "freetype jpeg tiff"
6SRCNAME = "Imaging"
7PR = "r5"
8
9SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
10 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
11 file://allow.to.disable.some.features.patch \
12 file://fix-freetype-includes.patch \
13 file://remove-host-libdir.patch \
14 file://python-imaging-CVE-2016-2533.patch \
15"
16
17SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
18SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21# There isn't enable/disable option, and lcms is in meta-oe, at least make it explicit when enabled
22# setup.py already has FIXME: add mechanism to explicitly *disable* the use of a library
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[lcms] = ",,lcms"
25
26inherit distutils
27
28do_compile() {
29 export STAGING_LIBDIR=${STAGING_LIBDIR}
30 export STAGING_INCDIR=${STAGING_INCDIR}
31 export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
32 distutils_do_compile
33}
34
35do_install() {
36 export STAGING_LIBDIR=${STAGING_LIBDIR}
37 export STAGING_INCDIR=${STAGING_INCDIR}
38 export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
39 distutils_do_install
40 install -d ${D}${datadir}/doc/${BPN}/html/
41 install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/
42 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${BPN}/html/
43
44 # get rid of #!/usr/local/bin/python
45 sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
46}
47
48RDEPENDS_${PN} += "python-lang python-stringold"