blob: 86303c359ad2e93312e9792ce29744c2e92ed3f7 [file] [log] [blame]
Duke Dudddc5012019-05-29 09:19:24 +08001SUMMARY = "OpenBMC Quanta Detect Fan Fail Service"
2DESCRIPTION = "OpenBMC Quanta Detect Fan Fail Daemon."
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${QUANTABASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11
12FILESEXTRAPATHS_append_gsj := "${THISDIR}/files:"
13SRC_URI_append_gsj = " file://detect-fan-fail.sh \
14 file://detect-fan-fail.service \
15 "
16
17do_install_append_gsj() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/detect-fan-fail.sh ${D}${bindir}/
20
21 install -d ${D}${systemd_unitdir}/system/
22 install -m 0644 ${WORKDIR}/detect-fan-fail.service ${D}${systemd_unitdir}/system
23}
24
25SYSTEMD_PACKAGES = "${PN}"
26SYSTEMD_SERVICE_${PN} = "detect-fan-fail.service"