blob: 3fe2c35ef4f42365a1a587c046ae8c8fe8f68fec [file] [log] [blame]
Patrick Williamsde0582f2022-04-08 10:23:27 -05001SUMMARY = "GNOME bluetooth manager"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
5 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
6"
7
8SECTION = "x11/gnome"
9
10DEPENDS = " \
11 udev \
12 libnotify \
13 libcanberra \
14 bluez5 \
15 upower \
16 gtk4 \
17 gsound \
18 libadwaita \
19"
20
21GNOMEBN = "gnome-bluetooth"
22S = "${WORKDIR}/${GNOMEBN}-${PV}"
23
24GNOMEBASEBUILDCLASS = "meson"
25GTKDOC_MESON_OPTION = "gtk_doc"
26GTKIC_VERSION = "4"
27
28inherit features_check gnomebase gtk-icon-cache gtk-doc gobject-introspection
29
30REQUIRED_DISTRO_FEATURES = "x11"
31
32SRC_URI[archive.sha256sum] = "3d1e2720673bc9a242619dc5d231fd6e776c18a49da29f43cdc433055adb0170"
33
34RDEPENDS:${PN} += "bluez5"
35
36FILES:${PN} += "${datadir}/gnome-bluetooth-3.0"